]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
discover/grub2: Allow to separate the --id argument using a space char
[petitboot] / test / parser / Makefile.am
index e4f9b9cfbc466d7e1c9bb02cf2bfa8f6ffefe357..748c8366c24c470d2260281c8246d3f985e911f0 100644 (file)
@@ -19,6 +19,8 @@ parser_TESTS = \
        test/parser/test-grub2-noeol \
        test/parser/test-grub2-menuentry-formats \
        test/parser/test-grub2-if-formats \
+       test/parser/test-grub2-default-id \
+       test/parser/test-grub2-default-id-space \
        test/parser/test-grub2-default-index \
        test/parser/test-grub2-default-multiword \
        test/parser/test-grub2-implicit-default-unset \
@@ -26,6 +28,7 @@ parser_TESTS = \
        test/parser/test-grub2-multiple-resolve \
        test/parser/test-grub2-multiple-id \
        test/parser/test-grub2-single-line-if \
+       test/parser/test-grub2-pos-param \
        test/parser/test-grub2-load-env \
        test/parser/test-grub2-save-env \
        test/parser/test-grub2-save-env-dash-f \
@@ -38,7 +41,15 @@ parser_TESTS = \
        test/parser/test-grub2-lexer-error \
        test/parser/test-grub2-parser-error \
        test/parser/test-grub2-test-file-ops \
+       test/parser/test-grub2-single-yocto \
+       test/parser/test-grub2-blscfg-default-filename \
+       test/parser/test-grub2-blscfg-default-index \
+       test/parser/test-grub2-blscfg-default-title \
+       test/parser/test-grub2-blscfg-multiple-bls \
+       test/parser/test-grub2-blscfg-opts-config \
+       test/parser/test-grub2-blscfg-opts-grubenv \
        test/parser/test-kboot-single \
+       test/parser/test-kboot-default \
        test/parser/test-yaboot-empty \
        test/parser/test-yaboot-single \
        test/parser/test-yaboot-partition \
@@ -56,6 +67,9 @@ parser_TESTS = \
        test/parser/test-pxe-initrd-in-append \
        test/parser/test-pxe-mac-without-conf \
        test/parser/test-pxe-ip-without-conf \
+       test/parser/test-pxe-ipxe \
+       test/parser/test-pxe-ipxe-named \
+       test/parser/test-pxe-ipxe-default \
        test/parser/test-pxe-non-url-conf \
        test/parser/test-pxe-local \
        test/parser/test-pxe-ipappend \
@@ -63,6 +77,7 @@ parser_TESTS = \
        test/parser/test-pxe-non-url-pathprefix-with-conf \
        test/parser/test-pxe-pathprefix-discover \
        test/parser/test-pxe-pathprefix-discover-mac \
+       test/parser/test-pxe-pathprefix-port \
        test/parser/test-pxe-path-resolve-relative \
        test/parser/test-pxe-path-resolve-absolute \
        test/parser/test-pxe-discover-bootfile-root \
@@ -70,7 +85,17 @@ parser_TESTS = \
        test/parser/test-pxe-discover-bootfile-pathprefix \
        test/parser/test-pxe-discover-bootfile-relative-conffile \
        test/parser/test-pxe-discover-bootfile-absolute-conffile \
-       test/parser/test-unresolved-remove
+       test/parser/test-pxe-discover-bootfile-async-file \
+       test/parser/test-unresolved-remove \
+       test/parser/test-syslinux-single-yocto \
+       test/parser/test-syslinux-global-append \
+       test/parser/test-syslinux-explicit \
+       test/parser/test-syslinux-nested-config \
+       test/parser/test-native-globals \
+       test/parser/test-native-short \
+       test/parser/test-native-simple \
+       test/parser/test-native-strings
+
 
 TESTS += $(parser_TESTS)
 check_PROGRAMS += $(parser_TESTS) test/parser/libtest.ro
@@ -79,7 +104,11 @@ check_DATA += \
        test/parser/data/grub2-f18-ppc64.conf \
        test/parser/data/grub2-f20-ppc.conf \
        test/parser/data/grub2-ubuntu-13_04-x86.conf \
-       test/parser/data/yaboot-rh8-ppc64.conf
+       test/parser/data/yaboot-rh8-ppc64.conf \
+       test/parser/data/syslinux-include-root.cfg \
+       test/parser/data/syslinux-include-nest-1.cfg \
+       test/parser/data/syslinux-include-nest-2.cfg \
+       test/parser/data/native-short.conf
 
 $(parser_TESTS): AM_CPPFLAGS += \
                -I$(top_srcdir)/discover \
@@ -99,10 +128,12 @@ test_parser_libtest_ro_SOURCES = \
        test/parser/utils.c \
        test/parser/handler.c \
        test/parser/network.c \
+       test/parser/user-event.c \
        test/parser/parser-test.h \
        discover/yaboot-parser.c \
        discover/kboot-parser.c \
        discover/pxe-parser.c \
+       discover/syslinux-parser.c \
        discover/platform.c \
        discover/resource.c \
        discover/paths.c \
@@ -110,13 +141,16 @@ test_parser_libtest_ro_SOURCES = \
        discover/parser-conf.c \
        discover/user-event.c \
        discover/event.c \
-       $(discover_grub2_grub2_parser_ro_SOURCES)
+       $(discover_grub2_grub2_parser_ro_SOURCES) \
+       $(discover_native_native_parser_ro_SOURCES)
 
 test_parser_libtest_ro_CPPFLAGS = \
        $(AM_CPPFLAGS) \
        -I$(top_srcdir)/discover \
        -I$(top_srcdir)/discover/grub2 \
        -I$(top_builddir)/discover/grub2 \
+       -I$(top_srcdir)/discover/native \
+       -I$(top_builddir)/discover/native \
        -DPETITBOOT_TEST \
        -DLOCAL_STATE_DIR='"$(localstatedir)"' \
        -DTEST_CONF_BASE='"$(top_srcdir)/test/parser/data"'