]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
discover/grub: Allow to set a default index for BLS entries
[petitboot] / test / parser / Makefile.am
index eb71a07dd1b76cafb3df7f361c4e296695a433e5..6ff3972d8316a32da57d579f2015a0145883fae8 100644 (file)
@@ -39,6 +39,13 @@ parser_TESTS = \
        test/parser/test-grub2-lexer-error \
        test/parser/test-grub2-parser-error \
        test/parser/test-grub2-test-file-ops \
+       test/parser/test-grub2-single-yocto \
+       test/parser/test-grub2-blscfg-default-filename \
+       test/parser/test-grub2-blscfg-default-index \
+       test/parser/test-grub2-blscfg-default-title \
+       test/parser/test-grub2-blscfg-multiple-bls \
+       test/parser/test-grub2-blscfg-opts-config \
+       test/parser/test-grub2-blscfg-opts-grubenv \
        test/parser/test-kboot-single \
        test/parser/test-yaboot-empty \
        test/parser/test-yaboot-single \
@@ -72,7 +79,12 @@ parser_TESTS = \
        test/parser/test-pxe-discover-bootfile-relative-conffile \
        test/parser/test-pxe-discover-bootfile-absolute-conffile \
        test/parser/test-pxe-discover-bootfile-async-file \
-       test/parser/test-unresolved-remove
+       test/parser/test-unresolved-remove \
+       test/parser/test-syslinux-single-yocto \
+       test/parser/test-syslinux-global-append \
+       test/parser/test-syslinux-explicit \
+       test/parser/test-syslinux-nested-config
+
 
 TESTS += $(parser_TESTS)
 check_PROGRAMS += $(parser_TESTS) test/parser/libtest.ro
@@ -81,7 +93,10 @@ check_DATA += \
        test/parser/data/grub2-f18-ppc64.conf \
        test/parser/data/grub2-f20-ppc.conf \
        test/parser/data/grub2-ubuntu-13_04-x86.conf \
-       test/parser/data/yaboot-rh8-ppc64.conf
+       test/parser/data/yaboot-rh8-ppc64.conf \
+       test/parser/data/syslinux-include-root.cfg \
+       test/parser/data/syslinux-include-nest-1.cfg \
+       test/parser/data/syslinux-include-nest-2.cfg
 
 $(parser_TESTS): AM_CPPFLAGS += \
                -I$(top_srcdir)/discover \
@@ -106,6 +121,7 @@ test_parser_libtest_ro_SOURCES = \
        discover/yaboot-parser.c \
        discover/kboot-parser.c \
        discover/pxe-parser.c \
+       discover/syslinux-parser.c \
        discover/platform.c \
        discover/resource.c \
        discover/paths.c \