]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
discover/grub: Allow to set a default index for BLS entries
[petitboot] / test / parser / Makefile.am
index 95ee0023bccf7c5f769a0a70de2ec533956c1fab..6ff3972d8316a32da57d579f2015a0145883fae8 100644 (file)
@@ -16,20 +16,36 @@ parser_TESTS = \
        test/parser/test-grub2-single \
        test/parser/test-grub2-default \
        test/parser/test-grub2-empty \
+       test/parser/test-grub2-noeol \
+       test/parser/test-grub2-menuentry-formats \
+       test/parser/test-grub2-if-formats \
        test/parser/test-grub2-default-index \
        test/parser/test-grub2-default-multiword \
+       test/parser/test-grub2-implicit-default-unset \
+       test/parser/test-grub2-implicit-default-invalid \
        test/parser/test-grub2-multiple-resolve \
        test/parser/test-grub2-multiple-id \
        test/parser/test-grub2-single-line-if \
+       test/parser/test-grub2-pos-param \
        test/parser/test-grub2-load-env \
        test/parser/test-grub2-save-env \
+       test/parser/test-grub2-save-env-dash-f \
        test/parser/test-grub2-saved-default \
        test/parser/test-grub2-nondefault-prefix \
        test/parser/test-grub2-f18-ppc64 \
        test/parser/test-grub2-f20-ppc64 \
        test/parser/test-grub2-ubuntu-13_04-x86 \
+       test/parser/test-grub2-sles-btrfs-snapshot \
        test/parser/test-grub2-lexer-error \
        test/parser/test-grub2-parser-error \
+       test/parser/test-grub2-test-file-ops \
+       test/parser/test-grub2-single-yocto \
+       test/parser/test-grub2-blscfg-default-filename \
+       test/parser/test-grub2-blscfg-default-index \
+       test/parser/test-grub2-blscfg-default-title \
+       test/parser/test-grub2-blscfg-multiple-bls \
+       test/parser/test-grub2-blscfg-opts-config \
+       test/parser/test-grub2-blscfg-opts-grubenv \
        test/parser/test-kboot-single \
        test/parser/test-yaboot-empty \
        test/parser/test-yaboot-single \
@@ -50,6 +66,7 @@ parser_TESTS = \
        test/parser/test-pxe-ip-without-conf \
        test/parser/test-pxe-non-url-conf \
        test/parser/test-pxe-local \
+       test/parser/test-pxe-ipappend \
        test/parser/test-pxe-pathprefix-with-conf \
        test/parser/test-pxe-non-url-pathprefix-with-conf \
        test/parser/test-pxe-pathprefix-discover \
@@ -61,7 +78,13 @@ parser_TESTS = \
        test/parser/test-pxe-discover-bootfile-pathprefix \
        test/parser/test-pxe-discover-bootfile-relative-conffile \
        test/parser/test-pxe-discover-bootfile-absolute-conffile \
-       test/parser/test-unresolved-remove
+       test/parser/test-pxe-discover-bootfile-async-file \
+       test/parser/test-unresolved-remove \
+       test/parser/test-syslinux-single-yocto \
+       test/parser/test-syslinux-global-append \
+       test/parser/test-syslinux-explicit \
+       test/parser/test-syslinux-nested-config
+
 
 TESTS += $(parser_TESTS)
 check_PROGRAMS += $(parser_TESTS) test/parser/libtest.ro
@@ -70,13 +93,16 @@ check_DATA += \
        test/parser/data/grub2-f18-ppc64.conf \
        test/parser/data/grub2-f20-ppc.conf \
        test/parser/data/grub2-ubuntu-13_04-x86.conf \
-       test/parser/data/yaboot-rh8-ppc64.conf
+       test/parser/data/yaboot-rh8-ppc64.conf \
+       test/parser/data/syslinux-include-root.cfg \
+       test/parser/data/syslinux-include-nest-1.cfg \
+       test/parser/data/syslinux-include-nest-2.cfg
 
 $(parser_TESTS): AM_CPPFLAGS += \
                -I$(top_srcdir)/discover \
                -DLOCAL_STATE_DIR='"$(localstatedir)"'
 $(parser_TESTS): LDADD += $@.embedded-config.o test/parser/libtest.ro $(core_lib)
-$(parser_TESTS): %: %.embedded-config.o test/parser/libtest.ro
+$(parser_TESTS): %: %.embedded-config.o test/parser/libtest.ro $(core_lib)
 
 extract_config = $(srcdir)/test/parser/extract-config.awk
 
@@ -89,10 +115,13 @@ test_parser_libtest_ro_SOURCES = \
        test/parser/main.c \
        test/parser/utils.c \
        test/parser/handler.c \
+       test/parser/network.c \
+       test/parser/user-event.c \
        test/parser/parser-test.h \
        discover/yaboot-parser.c \
        discover/kboot-parser.c \
        discover/pxe-parser.c \
+       discover/syslinux-parser.c \
        discover/platform.c \
        discover/resource.c \
        discover/paths.c \