]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
test/parser: test no whitespace on grub menuentry
[petitboot] / test / parser / Makefile.am
index e4f9b9cfbc466d7e1c9bb02cf2bfa8f6ffefe357..31300f091ee4edc13c4c3eca3a16e3f514b5bf08 100644 (file)
@@ -26,6 +26,7 @@ parser_TESTS = \
        test/parser/test-grub2-multiple-resolve \
        test/parser/test-grub2-multiple-id \
        test/parser/test-grub2-single-line-if \
+       test/parser/test-grub2-pos-param \
        test/parser/test-grub2-load-env \
        test/parser/test-grub2-save-env \
        test/parser/test-grub2-save-env-dash-f \
@@ -38,6 +39,7 @@ parser_TESTS = \
        test/parser/test-grub2-lexer-error \
        test/parser/test-grub2-parser-error \
        test/parser/test-grub2-test-file-ops \
+       test/parser/test-grub2-single-yocto \
        test/parser/test-kboot-single \
        test/parser/test-yaboot-empty \
        test/parser/test-yaboot-single \
@@ -70,6 +72,7 @@ parser_TESTS = \
        test/parser/test-pxe-discover-bootfile-pathprefix \
        test/parser/test-pxe-discover-bootfile-relative-conffile \
        test/parser/test-pxe-discover-bootfile-absolute-conffile \
+       test/parser/test-pxe-discover-bootfile-async-file \
        test/parser/test-unresolved-remove
 
 TESTS += $(parser_TESTS)
@@ -99,6 +102,7 @@ test_parser_libtest_ro_SOURCES = \
        test/parser/utils.c \
        test/parser/handler.c \
        test/parser/network.c \
+       test/parser/user-event.c \
        test/parser/parser-test.h \
        discover/yaboot-parser.c \
        discover/kboot-parser.c \