]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
grub2: fix empty file handling
[petitboot] / test / parser / Makefile.am
index e355af3e11ecd95dddd86b6b2bf0f3f392249f0e..283b284a621c84a3802f5cfefb5d9c3fcecf2e0c 100644 (file)
@@ -29,18 +29,23 @@ TESTS = \
        test-null \
        test-grub2-single \
        test-grub2-default \
+       test-grub2-empty \
        test-grub2-default-index \
        test-grub2-default-multiword \
        test-grub2-multiple-resolve \
+       test-grub2-multiple-id \
        test-grub2-single-line-if \
        test-grub2-load-env \
        test-grub2-save-env \
        test-grub2-saved-default \
+       test-grub2-nondefault-prefix \
        test-grub2-f18-ppc64 \
+       test-grub2-f20-ppc64 \
        test-grub2-ubuntu-13_04-x86 \
        test-grub2-lexer-error \
        test-grub2-parser-error \
        test-kboot-single \
+       test-yaboot-empty \
        test-yaboot-single \
        test-yaboot-partition \
        test-yaboot-partition-override \
@@ -48,6 +53,8 @@ TESTS = \
        test-yaboot-root-global \
        test-yaboot-root-override \
        test-yaboot-device-override \
+       test-yaboot-global-state \
+       test-yaboot-leftovers \
        test-yaboot-default \
        test-yaboot-rh8-ppc64 \
        test-pxe-empty \
@@ -56,7 +63,19 @@ TESTS = \
        test-pxe-mac-without-conf \
        test-pxe-ip-without-conf \
        test-pxe-non-url-conf \
-       test-pxe-local
+       test-pxe-local \
+       test-pxe-pathprefix-with-conf \
+       test-pxe-non-url-pathprefix-with-conf \
+       test-pxe-pathprefix-discover \
+       test-pxe-pathprefix-discover-mac \
+       test-pxe-path-resolve-relative \
+       test-pxe-path-resolve-absolute \
+       test-pxe-discover-bootfile-root \
+       test-pxe-discover-bootfile-subdir \
+       test-pxe-discover-bootfile-pathprefix \
+       test-pxe-discover-bootfile-relative-conffile \
+       test-pxe-discover-bootfile-absolute-conffile \
+       test-unresolved-remove
 
 $(TESTS): %: %.embedded-config.o
 $(TESTS): LDADD += $@.embedded-config.o
@@ -71,6 +90,7 @@ parser_objs = \
        $(top_srcdir)/discover/yaboot-parser.c \
        $(top_srcdir)/discover/kboot-parser.c \
        $(top_srcdir)/discover/pxe-parser.c \
+       $(top_srcdir)/discover/platform.c \
        $(top_srcdir)/discover/resource.c \
        $(top_srcdir)/discover/paths.c \
        $(top_srcdir)/discover/device-handler.c \
@@ -95,6 +115,7 @@ check_PROGRAMS = $(TESTS) libtest.ro
 
 check_DATA = \
        data/grub2-f18-ppc64.conf \
+       data/grub2-f20-ppc.conf \
        data/grub2-ubuntu-13_04-x86.conf \
        data/yaboot-rh8-ppc64.conf