]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
grub2: fix empty file handling
[petitboot] / test / parser / Makefile.am
index 9393b2a99b286fb7042e9296eb6751f58928da4d..283b284a621c84a3802f5cfefb5d9c3fcecf2e0c 100644 (file)
@@ -29,6 +29,7 @@ TESTS = \
        test-null \
        test-grub2-single \
        test-grub2-default \
+       test-grub2-empty \
        test-grub2-default-index \
        test-grub2-default-multiword \
        test-grub2-multiple-resolve \
@@ -67,6 +68,13 @@ TESTS = \
        test-pxe-non-url-pathprefix-with-conf \
        test-pxe-pathprefix-discover \
        test-pxe-pathprefix-discover-mac \
+       test-pxe-path-resolve-relative \
+       test-pxe-path-resolve-absolute \
+       test-pxe-discover-bootfile-root \
+       test-pxe-discover-bootfile-subdir \
+       test-pxe-discover-bootfile-pathprefix \
+       test-pxe-discover-bootfile-relative-conffile \
+       test-pxe-discover-bootfile-absolute-conffile \
        test-unresolved-remove
 
 $(TESTS): %: %.embedded-config.o
@@ -82,6 +90,7 @@ parser_objs = \
        $(top_srcdir)/discover/yaboot-parser.c \
        $(top_srcdir)/discover/kboot-parser.c \
        $(top_srcdir)/discover/pxe-parser.c \
+       $(top_srcdir)/discover/platform.c \
        $(top_srcdir)/discover/resource.c \
        $(top_srcdir)/discover/paths.c \
        $(top_srcdir)/discover/device-handler.c \