]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
discover/pxe-parser: Parse simple iPXE scripts
[petitboot] / test / parser / Makefile.am
index dddb4722109fb134caad769383d5167eef25dee5..1732158071f7cf66a631d5f45c9cce182ecae803 100644 (file)
@@ -26,6 +26,7 @@ parser_TESTS = \
        test/parser/test-grub2-multiple-resolve \
        test/parser/test-grub2-multiple-id \
        test/parser/test-grub2-single-line-if \
+       test/parser/test-grub2-pos-param \
        test/parser/test-grub2-load-env \
        test/parser/test-grub2-save-env \
        test/parser/test-grub2-save-env-dash-f \
@@ -37,6 +38,14 @@ parser_TESTS = \
        test/parser/test-grub2-sles-btrfs-snapshot \
        test/parser/test-grub2-lexer-error \
        test/parser/test-grub2-parser-error \
+       test/parser/test-grub2-test-file-ops \
+       test/parser/test-grub2-single-yocto \
+       test/parser/test-grub2-blscfg-default-filename \
+       test/parser/test-grub2-blscfg-default-index \
+       test/parser/test-grub2-blscfg-default-title \
+       test/parser/test-grub2-blscfg-multiple-bls \
+       test/parser/test-grub2-blscfg-opts-config \
+       test/parser/test-grub2-blscfg-opts-grubenv \
        test/parser/test-kboot-single \
        test/parser/test-yaboot-empty \
        test/parser/test-yaboot-single \
@@ -55,6 +64,9 @@ parser_TESTS = \
        test/parser/test-pxe-initrd-in-append \
        test/parser/test-pxe-mac-without-conf \
        test/parser/test-pxe-ip-without-conf \
+       test/parser/test-pxe-ipxe \
+       test/parser/test-pxe-ipxe-named \
+       test/parser/test-pxe-ipxe-default \
        test/parser/test-pxe-non-url-conf \
        test/parser/test-pxe-local \
        test/parser/test-pxe-ipappend \
@@ -69,7 +81,13 @@ parser_TESTS = \
        test/parser/test-pxe-discover-bootfile-pathprefix \
        test/parser/test-pxe-discover-bootfile-relative-conffile \
        test/parser/test-pxe-discover-bootfile-absolute-conffile \
-       test/parser/test-unresolved-remove
+       test/parser/test-pxe-discover-bootfile-async-file \
+       test/parser/test-unresolved-remove \
+       test/parser/test-syslinux-single-yocto \
+       test/parser/test-syslinux-global-append \
+       test/parser/test-syslinux-explicit \
+       test/parser/test-syslinux-nested-config
+
 
 TESTS += $(parser_TESTS)
 check_PROGRAMS += $(parser_TESTS) test/parser/libtest.ro
@@ -78,7 +96,10 @@ check_DATA += \
        test/parser/data/grub2-f18-ppc64.conf \
        test/parser/data/grub2-f20-ppc.conf \
        test/parser/data/grub2-ubuntu-13_04-x86.conf \
-       test/parser/data/yaboot-rh8-ppc64.conf
+       test/parser/data/yaboot-rh8-ppc64.conf \
+       test/parser/data/syslinux-include-root.cfg \
+       test/parser/data/syslinux-include-nest-1.cfg \
+       test/parser/data/syslinux-include-nest-2.cfg
 
 $(parser_TESTS): AM_CPPFLAGS += \
                -I$(top_srcdir)/discover \
@@ -98,10 +119,12 @@ test_parser_libtest_ro_SOURCES = \
        test/parser/utils.c \
        test/parser/handler.c \
        test/parser/network.c \
+       test/parser/user-event.c \
        test/parser/parser-test.h \
        discover/yaboot-parser.c \
        discover/kboot-parser.c \
        discover/pxe-parser.c \
+       discover/syslinux-parser.c \
        discover/platform.c \
        discover/resource.c \
        discover/paths.c \