]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
discover/grub2: improve handling of word & delimiter tokens
[petitboot] / test / parser / Makefile.am
index 95ee0023bccf7c5f769a0a70de2ec533956c1fab..072eba6fa9bfc56ec268de5faf32cd741f9261b2 100644 (file)
@@ -16,6 +16,9 @@ parser_TESTS = \
        test/parser/test-grub2-single \
        test/parser/test-grub2-default \
        test/parser/test-grub2-empty \
+       test/parser/test-grub2-noeol \
+       test/parser/test-grub2-menuentry-formats \
+       test/parser/test-grub2-if-formats \
        test/parser/test-grub2-default-index \
        test/parser/test-grub2-default-multiword \
        test/parser/test-grub2-multiple-resolve \
@@ -50,6 +53,7 @@ parser_TESTS = \
        test/parser/test-pxe-ip-without-conf \
        test/parser/test-pxe-non-url-conf \
        test/parser/test-pxe-local \
+       test/parser/test-pxe-ipappend \
        test/parser/test-pxe-pathprefix-with-conf \
        test/parser/test-pxe-non-url-pathprefix-with-conf \
        test/parser/test-pxe-pathprefix-discover \
@@ -76,7 +80,7 @@ $(parser_TESTS): AM_CPPFLAGS += \
                -I$(top_srcdir)/discover \
                -DLOCAL_STATE_DIR='"$(localstatedir)"'
 $(parser_TESTS): LDADD += $@.embedded-config.o test/parser/libtest.ro $(core_lib)
-$(parser_TESTS): %: %.embedded-config.o test/parser/libtest.ro
+$(parser_TESTS): %: %.embedded-config.o test/parser/libtest.ro $(core_lib)
 
 extract_config = $(srcdir)/test/parser/extract-config.awk