]> git.ozlabs.org Git - petitboot/blobdiff - test/lib/Makefile.am
test/efivar: Rework for efi_mount
[petitboot] / test / lib / Makefile.am
index 9636b08d6a6b83c359f1cc51608ffd3f56b1bdd8..65991a55d54a0a32256f4fe8d011e45e31bf81eb 100644 (file)
@@ -23,9 +23,17 @@ lib_TESTS = \
        test/lib/test-process-parent-stdout \
        test/lib/test-process-both \
        test/lib/test-process-stdout-eintr \
        test/lib/test-process-parent-stdout \
        test/lib/test-process-both \
        test/lib/test-process-stdout-eintr \
-       test/lib/test-fold
+       test/lib/test-fold \
+       test/lib/test-efivar
+
+if WITH_OPENSSL
+lib_TESTS += \
+       test/lib/test-security-openssl-verify \
+       test/lib/test-security-openssl-decrypt
+endif
 
 $(lib_TESTS): LIBS += $(core_lib)
 
 $(lib_TESTS): LIBS += $(core_lib)
+$(lib_TESTS): AM_CPPFLAGS += -DTEST_LIB_DATA_BASE='"$(abs_top_srcdir)/test/lib/data"'
 
 check_PROGRAMS += $(lib_TESTS)
 TESTS += $(lib_TESTS)
 
 check_PROGRAMS += $(lib_TESTS)
 TESTS += $(lib_TESTS)