]> git.ozlabs.org Git - petitboot/blobdiff - lib/Makefile.am
Display VERSION partition info on BMC machines
[petitboot] / lib / Makefile.am
index b39cc9bebef9f0bd5e9a3ae43dc739441394ce11..a3ae943861ba4f89f1b2230083e853f13800fbde 100644 (file)
@@ -26,6 +26,7 @@ lib_libpbcore_la_SOURCES = \
        lib/fold/fold.h \
        lib/fold/fold.c \
        lib/i18n/i18n.h \
        lib/fold/fold.h \
        lib/fold/fold.c \
        lib/i18n/i18n.h \
+       lib/i18n/i18n.c \
        lib/log/log.h \
        lib/log/log.c \
        lib/list/list.c \
        lib/log/log.h \
        lib/log/log.c \
        lib/list/list.c \
@@ -47,4 +48,21 @@ lib_libpbcore_la_SOURCES = \
        lib/url/url.c \
        lib/url/url.h \
        lib/util/util.c \
        lib/url/url.c \
        lib/url/url.h \
        lib/util/util.c \
-       lib/util/util.h
+       lib/util/util.h \
+       lib/flash/config.h \
+       lib/flash/flash.h
+
+if ENABLE_MTD
+lib_libpbcore_la_SOURCES += \
+       lib/flash/flash.c
+
+lib_libpbcore_la_CPPFLAGS += \
+       $(AM_CPPFLAGS)
+
+lib_libpbcore_la_LDFLAGS = \
+       $(AM_LDFLAGS) \
+       -l:libflash.so
+
+lib_libpbcore_la_SOURCES += \
+       lib/flash/flash.c
+endif