]> git.ozlabs.org Git - petitboot/blobdiff - lib/Makefile.am
discover/discover-server: Restrict clients based on uid
[petitboot] / lib / Makefile.am
index 59d37ab793dc9efd38760a95bb1b655a4df399d8..69a66c3735acc8734eeb8938f846c98865bd6a47 100644 (file)
@@ -35,6 +35,7 @@ lib_libpbcore_la_CFLAGS = \
 
 lib_libpbcore_la_SOURCES = \
        lib/ccan/endian/endian.h \
+       lib/crypt/crypt.h \
        lib/file/file.h \
        lib/file/file.c \
        lib/fold/fold.h \
@@ -67,7 +68,9 @@ lib_libpbcore_la_SOURCES = \
        lib/flash/flash.h \
        lib/security/security.h \
        lib/efi/efivar.h \
-       lib/efi/efivar.c
+       lib/efi/efivar.c \
+       lib/param_list/param_list.c \
+       lib/param_list/param_list.h
 
 if ENABLE_MTD
 lib_libpbcore_la_SOURCES += \
@@ -91,3 +94,11 @@ lib_libpbcore_la_SOURCES += \
        lib/security/none.c
 endif
 endif
+
+if ENABLE_CRYPT
+lib_libpbcore_la_SOURCES += \
+       lib/crypt/crypt.c
+
+lib_libpbcore_la_LDFLAGS += \
+       $(CRYPT_LIBS)
+endif