]> git.ozlabs.org Git - petitboot/blobdiff - lib/Makefile.am
discover: Add safe mode
[petitboot] / lib / Makefile.am
index e3ec2dc3b869296b1f69fb3434a9fdfd3da91243..5fc8911bd3f8988afbfc3f3725603974898dec9c 100644 (file)
@@ -12,6 +12,8 @@
 #  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
 #
 
+AUTOMAKE_OPTIONS = subdir-objects
+
 AM_CPPFLAGS = -I$(top_srcdir)/lib $(DEFAULT_CPPFLAGS) \
        -DPREFIX='"$(prefix)"'
 
@@ -20,6 +22,8 @@ AM_CFLAGS = $(DEFAULT_CFLAGS)
 noinst_LTLIBRARIES = libpbcore.la
 
 libpbcore_la_SOURCES = \
+       fold/fold.h \
+       fold/fold.c \
        log/log.h \
        log/log.c \
        list/list.c \
@@ -30,10 +34,6 @@ libpbcore_la_SOURCES = \
        pb-protocol/pb-protocol.h \
        pb-config/pb-config.c \
        pb-config/pb-config.h \
-       pb-config/storage.h \
-       pb-config/storage-powerpc-nvram.c \
-       pb-config/storage-null.c \
-       pb-config/storage-test.c \
        process/process.c \
        process/process.h \
        types/types.h \