]> git.ozlabs.org Git - petitboot/blobdiff - discover/Makefile.am
protocol: Separate device add from boot-option add messages
[petitboot] / discover / Makefile.am
index 6ace4004a52b45c6346ffa9c4e14c0004855f477..0e208357cfc1de34a62b55f691b84e4488a35508 100644 (file)
@@ -29,11 +29,20 @@ libparser_la_SOURCES = \
        parser-utils.c \
        parser-utils.h \
        paths.c \
-       paths.h
+       paths.h \
+       kboot-parser.c \
+       grub2-parser.c \
+       yaboot-parser.c
+
+EXTRA_DIST = native-parser.c
+
+libparser_la_LIBADD = $(top_builddir)/lib/libpbcore.la
 
-bin_PROGRAMS = pb-discover
+sbin_PROGRAMS = pb-discover
 
 pb_discover_SOURCES = \
+       boot.c \
+       boot.h \
        device-handler.c \
        device-handler.h \
        discover-server.c \
@@ -41,8 +50,6 @@ pb_discover_SOURCES = \
        event.c \
        event.h \
        event-parser.c \
-       kboot-parser.c \
-       message.h \
        params.c \
        params.h \
        pb-discover.c \
@@ -50,9 +57,8 @@ pb_discover_SOURCES = \
        udev.c \
        udev.h \
        user-event.c \
-       user-event.h \
-       yaboot-parser.c
+       user-event.h
+
 pb_discover_LDADD = libparser.la $(top_builddir)/lib/libpbcore.la
 
-EXTRA_DIST = native-parser.c
 MAINTAINERCLEANFILES = Makefile.in