]> git.ozlabs.org Git - petitboot/blobdiff - discover/Makefile.am
discover: Add setlocale calls in discover server
[petitboot] / discover / Makefile.am
index 2a7885d7c7c1ebb379578766a579ec21b9f8c5cc..01c29d790ef842bc8bf4b3d9d4ad9c03ab97e5a6 100644 (file)
@@ -16,7 +16,9 @@ pkgsysconfdir = @sysconfdir@/@PACKAGE@
 
 SUBDIRS = grub2
 
-AM_CPPFLAGS = -I$(top_srcdir)/lib $(DEFAULT_CPPFLAGS)
+AM_CPPFLAGS = -I$(top_srcdir)/lib \
+       -DLOCALEDIR='"$(localedir)"' \
+       $(DEFAULT_CPPFLAGS)
 
 AM_CFLAGS = $(DEFAULT_CFLAGS)  \
        -DPREFIX='"$(prefix)"' \
@@ -32,6 +34,8 @@ sbin_PROGRAMS = pb-discover
 pb_discover_SOURCES = \
        boot.c \
        boot.h \
+       cdrom.c \
+       cdrom.h \
        device-handler.c \
        device-handler.h \
        discover-server.c \
@@ -52,6 +56,9 @@ pb_discover_SOURCES = \
        paths.h \
        pb-discover.c \
        pb-discover.h \
+       platform.c \
+       platform.h \
+       platform-powerpc.c \
        resource.c \
        resource.h \
        sysinfo.c \